频道栏目
读书频道 > 移动开发 > 其他综合 > 黑莓(BlackBerry)开发从入门到精通
2.1.2 升级到BlackBerry Java SDK 6.0
2013-07-16 10:06:31     我来说两句
收藏   我要投稿
本书是一本全面介绍BlackBerry 智能手机技术的书籍。本书涉及了BlackBerry 开发的不同层面,主要内容包括:RIM 公司及BlackBerry 简介,BlackBerry 开发平台及其搭建,用户界面开发基础,用户界面之定制UI组...  立即去当当网订购

本小节介绍BlackBerry JDE Plug-In for Eclipse 环境中对组件包版本的升级。组件包版本升级后在功能和开发界面上会有一定的不同。本书所使用的BlackBerry JDE Plug-In for Eclipse环境都使用5.0的组件包为例,如果读者希望和本书内容保持一致,不希望升级组件包的话,可以跳过本小节。

在BlackBerry JDE Plug-In for Eclipse环境中,如果BlackBerry 的组件包有更新,可以直接在线升级组件包。如RIM 公司最新发布了BlackBerry Java SDK 6.0,里面包含BlackBerry JRE6.0组件,就可以通过在线升级的方式进行更新。

另外,如果开发人员已经有一个安装好的Eclipse,并没有安装BlackBerry 插件,也可以直接在安装好的Eclipse上在线安装BlackBerry Java SDK 6.0 。

对于从未安装过BlackBerry Plug-In的Eclipse 3.5 ,安装BlackBerry Java SDK 6.0的步骤如下:

1 )在Eclipse中选择“Help->Install New Software ”。

2 )在“Available Software”页的“Work with:”地址栏中输入以下地址:

http://www.blackberry.com/go/eclipseUpdate/3.5/java ,然后点击“Add ”按钮。

3 )待更新列表刷新后,选择“BlackBerry Java Plug-in”和“BlackBerry Java SDK 6.00.XX ”这两项,如果还需要安装别的BlackBerry Java SDK版本,也一并选择,如图2-11 所示。



4 )点击“Next”按钮,在下一页面点击“Finish ”按钮完成安装。

对于已经安装好BlackBerry 插件平台的Eclipse,如按上一小节安装的开发环境,同样可以通过在线安装将组件包版本升级到6.0。具体步骤如下:

1 )在Eclipse中选择“Help->Install New Software ”。

2 )在“Available Software”页的“Work with:”地址栏下拉列表中选择以下地址:

BlackBerry Java Plug-in Update Site - http://www.blackberry.com/go/eclipseUpdate/3.5/java。

3 )待更新列表刷新后,选择“BlackBerry Java SDK 6.00.XX”这一项,如图2-12 所示。

4 )点击“Next”按钮,在下一页面中点击“Finish ”按钮完成安装。

安装了BlackBerry Java SDK 6.0后,可以在对应的文件夹中查看6.0组件包的文档和模拟器。打开Eclipse 安装目录下的如下子目录:plugins\net.rim.ejde.componentpack 6.0.0_6.0.0.XX\components,其中SDK文档位于docs 目录下,模拟器位于simulator目录下。同时,组件包5.0的相关SDK文档和模拟器目录可以通过类似的方式找到,只是子目录的名称有所不同。打开6.0组件包的components目录后所看到的内容如图2-13 所示。

 
 

您对本文章有什么意见或着疑问吗?请到论坛讨论您的关注和建议是我们前行的参考和动力  
上一篇:2.1.1 BlackBerry JDE Plug-In for Eclipse 安装
下一篇:2.2.1 建立BlackBerry项目
相关文章
图文推荐
排行
热门
最新书评
文章
下载
读书
特别推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站