频道栏目
读书频道 > 移动开发 > 其他综合 > iOS 5 cocos2d 游戏开发实战(第2版)
2.1.1 系统要求
2012-10-17 14:26:56     我来说两句
收藏   我要投稿
《iOS 5 cocos2d游戏开发实战(第2版)》将引导您开发富有吸引力的2D游戏。书中展示了如何使用cocos2d这款强大的游戏引擎来开发iPhone和iPad游戏,此外还介绍了游戏中的瓦片地图、虚拟摇杆、Game Center等。本书...  立即去当当网订购

2.1  准备工作

在本节中,首先介绍一些最基本的准备工作。由于苹果公司官方已经有详细的文档来说明如何注册成为iOS 开发者,以及如何创建必需的授权文件,因此这里我就不作过多解释了。

2.1.1  系统要求

为了开发iOS 应用程序,软硬件必须符合以下要求:

●  基于Intel处理器  + 1GB RAM的Mac计算机

●  Mac OS X 10.6(Snow Leopard)或更高版本的操作系统

●  任何iOS 设备

就开发而言,任何基于Intel处理器的Mac计算机都是满足要求的。即使是Mac  mini和MacBook Air,也能很好地满足iOS应用程序或游戏的开发需求。尽管对RAM(Random Access Memory,随机访问存储器)的最低要求是1GB,但我还是推荐安装2GB或更多内存。相比其他软件,游戏开发工具对内存的需求往往要大得多;所以,如果条件允许,就请按照我推荐的那样做吧,这样可以使计算机运行得更为流畅。要知道,你将要处理的是大量的图像、音频文件以及程序代码,并且很有可能需要同时运行所有这些工具。

注意,自2010年6月iPhone SDK 4 发布以来,iOS 开发就必须在Mac OS X 10.6版本中进行。Mac OS X 10.7 Lion发布以后,可以想到最终它将成为iOS 开发的必需版本。作为使用苹果公司产品的开发人员,总是需要使用最新的OS X版本。

如果你正在使用旧版本的Mac  OS  X,请到Mac  OS  X的技术规格说明网站(http://www.apple.com/macosx/specs.html)检查你的Mac是否符合系统要求以及如何购买并升级到最新的Mac OS X版本。

您对本文章有什么意见或着疑问吗?请到论坛讨论您的关注和建议是我们前行的参考和动力  
上一篇:概述
下一篇:2.1.2 注册成为iOS 开发者
相关文章
图文推荐
排行
热门
最新书评
文章
下载
读书
特别推荐

关于我们 | 联系我们 | 广告服务 | 投资合作 | 版权申明 | 在线帮助 | 网站地图 | 作品发布 | Vip技术培训 | 举报中心

版权所有: 红黑联盟--致力于做实用的IT技术学习网站